Rickenbacker International Corporation - Forum
http://rickenbacker.com/forum/

Brand New 325c64 Bridge pick up just died
http://rickenbacker.com/forum/viewtopic.php?f=4&t=16181
Page 1 of 1

Author:  RickenRobbie325c [ Fri Apr 01, 2016 5:11 pm ]
Post subject:  Brand New 325c64 Bridge pick up just died

Well this is a bummer. I just got a brand new Ric 325c64.

I have had it about 2 weeks. Today while jamming switched the pick up selector to the bridge pick up for some jingle jangle. Heard zzzz zzzzz scratch and nothing.

Middle and neck work fine. Tried new cords, different amps, nothing.

Removed picjguar to take a peak. Everything looks brand new and as it should. I have no idea. All solder points look good, harness looks fine.

Any ideas? Please? I have a bunch of other Rics and this has never happened. Especially only owning the guitar for two weeks!

Author:  Uffingdon [ Fri Apr 01, 2016 10:03 pm ]
Post subject:  Re: Brand New 325c64 Bridge pick up just died

Could just be a bad connection at the switch, try running a bit of fine sandpaper through the contacts.

Author:  iiipopes [ Mon Apr 04, 2016 11:40 am ]
Post subject:  Re: Brand New 325c64 Bridge pick up just died

No! Not sandpaper - a pencil eraser to remove any corrosion. Once you remove metal, you can't get it back!

Author:  RickenRobbie325c [ Mon Apr 04, 2016 1:50 pm ]
Post subject:  Re: Brand New 325c64 Bridge pick up just died

Just going to bring it back to the Ric authorized dealer where it was purchased on 3/10/2016. Do not want to mess with the tricky warranty guidelines and possible voiding.

Author:  Aoresteen [ Sat Apr 08, 2017 5:55 pm ]
Post subject:  Re: Brand New 325c64 Bridge pick up just died

Most likely it is the switch. Let us know what failed.

Author:  winston52 [ Fri Apr 21, 2017 7:46 am ]
Post subject:  Re: Brand New 325c64 Bridge pick up just died

Any good news?

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/